import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^---)((?:(?!^---)[\\s\\S])+?^date:\\s*)(.+)((?:(?!^---)[\\s\\S])+?)(^---)";
final String string = "---\n"
+ "title: test\n"
+ "date: 2018/10/17\n"
+ "description: some thing\n"
+ "---\n\n\n"
+ "lorem ipsum\n"
+ "date: 2018/10/18\n"
+ "lorem ipsum\n\n"
+ "---\n"
+ "title: test\n"
+ "date: 2018/10/17\n"
+ "description: some thing\n"
+ "---\n\n"
+ "---\n"
+ "title: test\n"
+ "nodatehere:\n"
+ "description: some thing\n"
+ "---";
final String subst = "$1$2substitution$4$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}