re = /(\/\*[\s\S]*?(.*?)\*\/)|(\/\/.*)/m
str = '/*
function to do things with
*/
function myFunction() {
this.x=55; //Some value
//start the function
this.start();
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end