#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\s+\/inference=".+)\n\s+(\s+([^\/\n]+\n){1,2})(\s+\/codon_start=.+)"
Local $sString = " /inference="blah" & @CRLF & _
" blah" & @CRLF & _
" BLAH" & @CRLF & _
" /codon_start=blah" & @CRLF & _
"" & @CRLF & _
" /inference="similar" & @CRLF & _
" /codon_start=blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")