package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\+?6?01)[0|1|2|3|4|6|7|8|9]\-*[0-9]{7,8}$`)
var str = `0143678890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}