$re = '/^(\+?6?01)[0|1|2|3|4|6|7|8|9]\-*[0-9]{7,8}$/';
$str = '0143678890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);