#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^_]*"
Local $sString = "a_a_a"
Local $sSubst = "b"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)