const regex = /(?:\d{2}\/\d{2}\/\d{4}|₪ \d{1,3}(?:,\d{3})*(?:\.\d+)?| ?\w+(?: \w+)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\d{2}\\\/\\d{2}\\\/\\d{4}|₪ \\d{1,3}(?:,\\d{3})*(?:\\.\\d+)?| ?\\w+(?: \\w+)*)', 'gm')
const str = `2, some text,9740127,"₪ 38,850.00","₪ 5,550.00","₪ 28,305","₪ 4,995",22/05/2020
`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);