# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\s)Äpfel(?=$|\s)/$1*****/g;t' <<< "ich mag Äpfel"