#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|\s)Äpfel(?=$|\s)"
Local $sString = "ich mag Äpfel"
Local $sSubst = "$1*****"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)