use strict;
my $str = 'ich mag Äpfel';
my $regex = qr/(^|\s)Äpfel(?=$|\s)/p;
my $subst = '$1*****';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";