$re = '/(^|\s)Äpfel(?=$|\s)/';
$str = 'ich mag Äpfel';
$subst = "$1*****";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;