# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^\n\d]*(\d+)(?:[^\n\d]+(\d+))?(?:[^\n\d]+(\d+))?.*/$1 $2 $3/gm;t' <<< "T441_S45/1
007_S4
41_445T02_74
"