package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(CASE\s+WHEN.*?END)`)
var str = `iduser + CaSe WhEn ("end") = 0 THEN 'CASE WHEN' ELSE 'END' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}