const regex = /(?i)(CASE\s+WHEN.*?END)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(CASE\\s+WHEN.*?END)', 'g')
const str = `iduser + CaSe WhEn ("end") = 0 THEN 'CASE WHEN' ELSE 'END' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}