re = /(?i)(CASE\s+WHEN.*?(?<!['"])END)/
str = 'iduser + CaSe WhEn ("end") = 0 THEN \'CASE WHEN\' ELSE \'END\' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end