# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(?:\d(?:\.\d+)?\s*x\s*)?\K(?<!\d)\d+(?:\.\d+)?(?:k?g|m?l)\b|(?<!\d)\d+(?:\.\d+)?(?:k?g|m?l)(?=\s*x\s*\d)"
test_str = ("product brand A 1237ml Bundle of 6\n"
"product milk choc370ML\n"
"brand milk Vanilla Flavor 850g\n"
"One 2400g, For 0-6 Month-Old Infants\n"
"a+...two...6-12months...11.2kg...milk\n"
"a+...two...11.2kg 6-12months ..milk\n"
"Product 200g (10x2g)\n"
"[200g] Product\n"
"Product A brand(300g)\n"
"Product 200g (20g x 10)")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.