#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?um)\bfile (?i)([a-z_][a-z0-9_]*+|"(?:[^"]|(?<=\\)")*+"|\([^()]*+(?:\([^()]*+(?:\([^()]*+\)[^()]*+)*+\)[^()]*+)*+\)|\|[^|]*+\|)"
Local $sString = "set filePath to (path to desktop as text) & "Test.txt"" & @CRLF & _
"set theText to read file filePath"
Local $sSubst = "(\1 as «class furl»)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)