const regex = /[^\r\n\s]*\.(rsgsv|rsgsv\.net)($|\/[^\r\n\s]*|\s).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\r\\n\\s]*\\.(rsgsv|rsgsv\\.net)($|\\\/[^\\r\\n\\s]*|\\s).*', 'gm')
const str = `bounce-mc.us17_88678681.378839-tri.susanti=balaikartini.com@mail78.suw151.rsgsv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}