using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ +\K[\w ]+(?= )";
string input = @" cccc cccc - fff
cccc cccc ‒ fff
cccc cccc – fff
cccc cccc — fff
cccc cccc ― fff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}