#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{8}(?:\d{2}(?:\d{2})?)?|\(\+?\d{2,3}\)\s?(?:\d{4}[\s*.-]?\d{4}|\d{3}[\s*.-]?\d{3}|\d{2}([\s*.-]?)\d{2}\1\d{2}(?:\1\d{2})?))$"
Local $sString = "It can contain open and close parenthesis ex. (55)" & @CRLF & _
"It can contin or not '+' char ex. (+52)" & @CRLF & _
"It can contain 2 or 3 numbers inside parenthesis ex. (+555) o (+55)" & @CRLF & _
"It can contain whitespace between close parenthesis and the next numbers ex. (55) 44332211" & @CRLF & _
"The consecutive numbers to the parenthesis must be 6 or 8 numbers ex. (55)443322 o (55)44332211" & @CRLF & _
"The consecutive numbers to the parenthesis can contain whitespaces, dashes, asterisks, or colons. ex.(55)44-33-22-11 o (55)44 33 22 11 o (55)44*33*22*11 o (55)44.33.22.11" & @CRLF & _
"The consecutive numbers to the parenthesis can be divided in groups of 2, 3 or 4 numbers ex. (55)5544-3322 o (55)55 44 33 22 o (555)444*333" & @CRLF & _
"The number format can come in a row of 8, 10 o 12 numbers ex. 55443322 o 5544332211 o 554433221100" & @CRLF & _
"(55)test" & @CRLF & _
"(55)333-test" & @CRLF & _
"(55)test 22" & @CRLF & _
"554433221100" & @CRLF & _
"5544332211" & @CRLF & _
"55443322" & @CRLF & _
"(55)443322" & @CRLF & _
"(55)44332211" & @CRLF & _
"(+55)443322" & @CRLF & _
"(+55)44332211" & @CRLF & _
"(55)4433*2211" & @CRLF & _
"(55)444.333" & @CRLF & _
"(55)44-33-22-11" & @CRLF & _
"(55)4433-2211" & @CRLF & _
"(+55)443 322"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")