use strict;
my $str = 'It can contain open and close parenthesis ex. (55)
It can contin or not \'+\' char ex. (+52)
It can contain 2 or 3 numbers inside parenthesis ex. (+555) o (+55)
It can contain whitespace between close parenthesis and the next numbers ex. (55) 44332211
The consecutive numbers to the parenthesis must be 6 or 8 numbers ex. (55)443322 o (55)44332211
The consecutive numbers to the parenthesis can contain whitespaces, dashes, asterisks, or colons. ex.(55)44-33-22-11 o (55)44 33 22 11 o (55)44*33*22*11 o (55)44.33.22.11
The consecutive numbers to the parenthesis can be divided in groups of 2, 3 or 4 numbers ex. (55)5544-3322 o (55)55 44 33 22 o (555)444*333
The number format can come in a row of 8, 10 o 12 numbers ex. 55443322 o 5544332211 o 554433221100
(55)test
(55)333-test
(55)test 22
554433221100
5544332211
55443322
(55)443322
(55)44332211
(+55)443322
(+55)44332211
(55)4433*2211
(55)444.333
(55)44-33-22-11
(55)4433-2211
(+55)443 322';
my $regex = qr/^(?:\d{8}(?:\d{2}(?:\d{2})?)?|\(\+?\d{2,3}\)\s?(?:\d{4}[\s*.-]?\d{4}|\d{3}[\s*.-]?\d{3}|\d{2}([\s*.-]?)\d{2}\1\d{2}(?:\1\d{2})?))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}