#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)name="csrfmiddlewaretoken"\svalue="\s?(\w+)""
Local $sString = "<input type="hidden" name="csrfmiddlewaretoken" value="mfvj33UuJiX9sjoKhhJMZENQjLwLKUlFlUeRLmhQ3DXNTOmggftnMJRvZlbTtNTg">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")