re = /name="csrfmiddlewaretoken"\svalue="\s?(\w+)"/m
str = '<input type="hidden" name="csrfmiddlewaretoken" value="mfvj33UuJiX9sjoKhhJMZENQjLwLKUlFlUeRLmhQ3DXNTOmggftnMJRvZlbTtNTg">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end