# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\G(?!\A)\w+|\b(?:where|there)\b)\./$1_/g;t' <<< "hey where.is.the book on.brown.table
hey there.is.a.boy.in.the city Delhi
hey here.is.the.boy living next door"