#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\G(?!\A)\w+|\b(?:where|there)\b)\."
Local $sString = "hey where.is.the book on.brown.table " & @CRLF & _
"hey there.is.a.boy.in.the city Delhi" & @CRLF & _
"hey here.is.the.boy living next door"
Local $sSubst = "$1_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)