$re = '/^.+?\s(.*)/m';
$str = '50G This is a Test (0000) 1234p (String).ext';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;