httpthe literal text http (case sensitive) s?optionally matches the literal s (11510 / 1638 / 7316) (case sensitive)
:the literal : (5810 / 728 / 3A16)
\/the literal / (4710 / 578 / 2F16)
\/the literal / (4710 / 578 / 2F16)
Non-Capturing Group(?:www\.)? ?repeats the group contents below at most once:
wwwthe literal text www (case sensitive) \.the literal . (4610 / 568 / 2E16)
instagramthe literal text instagram (case sensitive) \.the literal . (4610 / 568 / 2E16)
comthe literal text com (case sensitive) Non-Capturing Group(?:\/[^\/]+)? ?repeats the group contents below at most once:
\/the literal / (4710 / 578 / 2F16)
Negated Character Class[^\/]+ +matches at least one character outside the set below:
\/the literal / (4710 / 578 / 2F16)
\/the literal / (4710 / 578 / 2F16)
Non-Capturing Group(?:p|tv|reel) pthe literal p (11210 / 1608 / 7016) (case sensitive)
tvthe literal text tv (case sensitive) reelthe literal text reel (case sensitive) \/the literal / (4710 / 578 / 2F16)
Negated Character Class[^\/?#&]+ +matches at least one character outside the set below:
\/the literal / (4710 / 578 / 2F16)
?the literal ? (6310 / 778 / 3F16)
#the literal # (3510 / 438 / 2316)
&the literal & (3810 / 468 / 2616)
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string