use strict;
my $str = 'https://instagram.com/p/aye83DjauH/?foo=bar#abc
https://www.instagram.com/reel/Chunk8-jurw/
https://www.instagram.com/p/BQ0eAlwhDrw/
https://www.instagram.com/tv/BkfuX9UB-eK/
https://instagram.com/p/-Cmh1cukG2/
http://instagram.com/p/9o6LshA7zy/embed/
https://www.instagram.com/tv/aye83DjauH/
https://www.instagram.com/reel/CDUMkliABpa/
https://www.instagram.com/marvelskies.fc/reel/CWqAgUZgCku/';
my $regex = qr/https?:\/\/(?:www\.)?instagram\.com(?:\/[^\/]+)?\/(?:p|tv|reel)\/([^\/?#&]+)/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}