# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/&redirect_uri=\S+?localhost\K%[^%]+//g;t' <<< "https://www.facebook.com/v2.5/dialog/oauth?client_id=*****&state=*****&response_type=code&sdk=php-sdk-5.1.2&redirect_uri=http%3A%2F%2Flocalhost%3A8888%2Ffacebook%2Flink&scope=email%2Cuser_birthday%2Cuser_photos"