const regex = /&redirect_uri=\S+?localhost\K%[^%]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&redirect_uri=\\S+?localhost\\K%[^%]+', 'g')
const str = `https://www.facebook.com/v2.5/dialog/oauth?client_id=*****&state=*****&response_type=code&sdk=php-sdk-5.1.2&redirect_uri=http%3A%2F%2Flocalhost%3A8888%2Ffacebook%2Flink&scope=email%2Cuser_birthday%2Cuser_photos`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);