use strict;
my $str = 'aDepartment of test, kHospital of test';
my $regex = qr/[a-z]([A-Z])/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";