re = /((?<=is).[0-9]{4,8}.(?=is)?)|(^[0-9]{4,8}.(?= is))/m
str = 'OTP for YONO transaction in SBI is 449270. Do not share it with anyone by any means. This is confidential and to be used by you only.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end