$re = '/"email":"?[\._a-zA-Z0-9-]+@[\._a-zA-Z0-9-]+"?/m';
$str = '"email":"email@domain.com"
"email":email@domain.com
email:"email@domain.com"
"email@domain.com"
email@domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);