package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[[:xdigit:]]{8}(?:\-[[:xdigit:]]{4}){3}\-[[:xdigit:]]{12}$`)
var str = `2f106095-bd0b-4476-9747-ac4808d42ddf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}