const regex = /^[[:xdigit:]]{8}(?:\-[[:xdigit:]]{4}){3}\-[[:xdigit:]]{12}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[[:xdigit:]]{8}(?:\\-[[:xdigit:]]{4}){3}\\-[[:xdigit:]]{12}$', 'gm')
const str = `2f106095-bd0b-4476-9747-ac4808d42ddf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}