use strict;
my $str = 'myregistryhost:5000/fedora/httpd:version1.0@sha256:0123456789abcdef0123456789abcdef0123456789abcdef0123456789abcdef';
my $regex = qr/^(?P<name>(?:(?:(?P<hostname>(?=[^:\/]{4,253})(?!-)[a-zA-Z0-9-]{1,63}(?<!-)(?:\.(?!-)[a-zA-Z0-9-]{1,63}(?<!-))*)(?::(?P<port>[0-9]{1,5}))?)/)?(?P<registry>(?![._-])(?:[a-z0-9._-]*)(?<![._-])(?:/(?![._-])[a-z0-9._-]*(?<![._-]))*))(?::(?P<tag>(?![.-])[a-zA-Z0-9_.-]{1,128}))?(?:@sha256:(?P<digest>[a-f0-9]{64}))?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}