// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:[01][0-9]|2[0-3])[0-5][0-9]\b").unwrap();
let string = "2359
0000
1330
2400
2360
2500
1322
0001
2500
2400
2359
0123
4321
2059";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}