using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(.+?\))(?=\s)";
string input = @"Công ty (a(df)ad) hữu hạn (TNHH))))sdfsdfsd)))))
Công ty (((CT))) trách nhiệm hữu hạn (TNHH)
Công ty (a(df)ad) hữu hạn (TNHH)
Công ty ((bbbbb(CTrrrr)dddđ)) trách nhiệm hữu hạn (TN(((((((HH) ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}