re = /(\(.+?\))(?=\s)/m
str = 'Công ty (a(df)ad) hữu hạn (TNHH))))sdfsdfsd)))))
Công ty (((CT))) trách nhiệm hữu hạn (TNHH)
Công ty (a(df)ad) hữu hạn (TNHH)
Công ty ((bbbbb(CTrrrr)dddđ)) trách nhiệm hữu hạn (TN(((((((HH) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end