package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^"\r\n]+(?:"[^"]*"[^"\r\n]+)*`)
var str = `Row 1: bla bla, 12345,
Row 2: "bla
bla", 12345, ...
Row 3: bla bla, 12345,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}