re = /\{\"\w*\"\:\[\d*\.\d*\,\d*\.\d*\]\,\"t\"\:2\}/m
str = '{"location":[55.32168,140.556],"t":2}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end