using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""Assigned Workgroup"" in \()[""?\w""?|,]*\""(Business Service Management)";
string input = @"project in (KISHORE_TEST, ""Business Service Management"") AND ""Assigned Workgroup"" in (KISHORE_TEST,""Business Service Management"", ""Account"",""BSM Automation"") OR ""Workgroup"" in (""BSM Automation"") OR ""Assigned Workgroup"" in (""Business Service Management"",""BSM Automation"") AND ""Assigned Workgroup"" in (""KISHORE_TEST"",""Business Service Management"", ""Account"",""BSM Automation"") OR ""Assigned Workgroup"" in (""BSM Automation"") and team = ""Business Service Management""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}