import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-|\\+)??(180(\\.0+?)??|(1[0-7]|\\d)\\d??(\\.\\d+?)??)$";
final String string = "// Valid longitude values\n"
+ "180\n"
+ "180.000\n"
+ "179\n"
+ "179.0\n"
+ "179.999\n"
+ "100\n"
+ "100.00\n"
+ "100.9\n"
+ "99\n"
+ "99.99\n"
+ "99.0\n"
+ "80\n"
+ "10\n"
+ "10.00\n"
+ "10.99\n"
+ "8\n"
+ "8.9\n"
+ "8.0\n"
+ "1\n"
+ "1.0\n"
+ "1.9\n"
+ "0\n"
+ "0.1\n"
+ "0.9\n"
+ "+180\n"
+ "+180.000\n"
+ "+179\n"
+ "+179.0\n"
+ "+179.999\n"
+ "+100\n"
+ "+100.00\n"
+ "+100.9\n"
+ "+99\n"
+ "+99.99\n"
+ "+99.0\n"
+ "+80\n"
+ "+10\n"
+ "+10.00\n"
+ "+10.99\n"
+ "+8\n"
+ "+8.9\n"
+ "+8.0\n"
+ "+1\n"
+ "+1.0\n"
+ "+1.9\n"
+ "+0\n"
+ "+0.1\n"
+ "+0.9\n"
+ "-180\n"
+ "-180.000\n"
+ "-179\n"
+ "-179.0\n"
+ "-179.999\n"
+ "-100\n"
+ "-100.00\n"
+ "-100.9\n"
+ "-99\n"
+ "-99.99\n"
+ "-99.0\n"
+ "-80\n"
+ "-10\n"
+ "-10.00\n"
+ "-10.99\n"
+ "-8\n"
+ "-8.9\n"
+ "-8.0\n"
+ "-1\n"
+ "-1.0\n"
+ "-1.9\n"
+ "-0\n"
+ "-0.1\n"
+ "-0.9\n"
+ "// Invalid longitude values\n"
+ "181\n"
+ "180.00001\n"
+ "180.1\n"
+ "180.9\n"
+ "-181\n"
+ "-180.00001\n"
+ "-180.1\n"
+ "-180.9\n"
+ "+181\n"
+ "+180.00001\n"
+ "+180.1\n"
+ "+180.9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}