const regex = /(?:\G(?!^)|\w{2}(?=\w*$))\K\w(?=\w{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|\\w{2}(?=\\w*$))\\K\\w(?=\\w{2})', 'gm')
const str = `ABCEDFG`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);