$re = '/(?:\G(?!^)|\w{2}(?=\w*$))\K\w(?=\w{2})/m';
$str = 'ABCEDFG';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;