using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-](?:webkit|moz|op|ms)(?:[-][a-zA-Z0-9]{2,})+";
string input = @"-webkit-aultofill
-moz-read-only
-moz
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}