$re = '/\b(?:field[1234])=\S+\b(?=.*\btype=a\b)
|
(?<=\btype=a\b.*)\b(?:field[1234])=\S+\b/mx';
$str = 'field1=foo this=garbage field2=bar type=a field3=now
field1=foo field2=bar type=b field3=now
field1=bar type=a field3=foo this=garbage field4=hithere
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);