#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\[]\w+\)[^\]]"
Local $sString = "<table" & @CRLF & _
" [box]="teamsTypes"" & @CRLF & _
" [(bananInBox)]="bananInBox"" & @CRLF & _
" (banan)="createDialog()"" & @CRLF & _
" class="class"" & @CRLF & _
" mat-table" & @CRLF & _
" >" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")