$re = '/\s+\[.*?(?=\S+$)/m';
$str = '15-16-00-014716 AND15- [ ] (5) Description of 16-00-014715
15-16-00-014716 AND15- [ ] (5) Description of 1600014715';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;