re = /(?<=name: )[a-z]+/mi
str = 'Data sample
(Ref: FSH 6509.14)
1. Employee Name: Chris
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end